Verification is currently underway for the maintenance items.
Posted Jul 23, 2026 - 20:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 23, 2026 - 20:00 EDT
Scheduled
Team, The Infrastructure Team will be conducting routine firewall testing during an upcoming maintenance window. During this time, access to various systems and services may be limited or temporarily unavailable, including but not limited to:
We appreciate your patience and understanding as we perform these tests to ensure the continued reliability and security of our network infrastructure.
Thank you, Infrastructure Team
Posted Jul 22, 2026 - 08:28 EDT
This scheduled maintenance affected: Network Services (Internet Access - Plantation, Virtual Private Network (VPN)) and Internal Services (ImageRight Server, File Server (R drive), Automation Tasks, Azure Virtual Desktop, Domain Authentication).