Issues With Microsoft Outlook

Incident Report for Responsive Auto

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 09:21 EST

Investigating

We are currently investigating an issue with MS Outlook not receiving emails. Microsoft seems to be experiencing problems with Office 365.
Posted Jan 22, 2026 - 15:53 EST