Login issue with TLO and possible other sites and services

Incident Report for Responsive Auto

Resolved

We have been notified that the Cloudflare issues have been resolved. If you experience any issues, please open a service desk ticket.
Posted Nov 18, 2025 - 16:57 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 10:19 EST

Identified

The error message "Please unblock challenges.cloudflare.com"
We may also have issues with processing payments


There is an issue with the Cloudflare service that may cause connection issues with other websites as well.

Cloudflare was hit by an outage that knocked several major websites and services offline for global users.
OpenAI's ChatGPT, e-commerce platform Shopify and Elon Musk's social media platform X appear to have been affected by the Cloudflare issues.
A Cloudflare spokesperson said the company observed a "spike in unusual traffic" to one of its services before the errors.
Posted Nov 18, 2025 - 09:35 EST