Monitoring October 16th, 2025, 1:10 pm EDT 8x8 has worked with the remaining customers impacted and confirmed that clearing the web browser cache and cookies resolved any Agent Workspace login issues. Please ensure cookies are cleared at minimum for the last 24hrs. We will continue to monitor and will provide a final update once fully confirmed.
If, after clearing cache and cookies, a user is still unable to log in, please contact 8x8 support to continue troubleshooting.
Instructions to Clear cache and cookies
Posted Oct 16, 2025 - 14:30 EDT
Update
Incident October 16th 2025, 10:51am EDT 8x8 Agent Workspace not loading Status: in progress Start: October 16th 2025, 9:16am EDT Affected Components: Americas Contact Center Contact Center US1 Contact Center US2 Contact Center SK1 NA1 CA1 NA2 NA7 CA2 NA3 NA8 NA37 NA4 NA9 NA38 NA5 NA10 NA6 NA17 NA11 NA18 NA12 NA19 NA13 NA20 NA14 NA27 NA15 NA28 SB1 NA29 NA37 NA38 NA30 NA39 InvestigatingOctober 16th 2025, 9:16am EDT 8x8 Is currently investigating reports of Agent Workspace not loading. We are working on resolving the issue and updates will be provided as they become available.
UpdateOctober 16th 2025, 9:32am EDT Our engineers are currently working to resolve the issue impacting Agent Workspace, causing it to spin indefinitely. We will continue to provide updates as they become available.
UpdateOctober 16th 2025, 10:00am EDT 8x8 engineers continue to work towards resolution of the issue. We will continue to provide updates as they become available and we apologize for the inconvenience.
UpdateOctober 16th 2025, 10:25am EDT We are doing our very best to get this issue resolved as a matter of priority, we thank you for your patience. We will provide further update as they become available and we again apologize for the inconvenience.
UpdateOctober 16th 2025, 10:51am EDT 8x8 engineers continue to work towards resolution of the issue. We will continue to provide updates as they become available and we apologize for the inconvenience.
Posted Oct 16, 2025 - 11:25 EDT
Investigating
8x8 has confirmed that they are experiencing an issue with the VCC functions. Try to use MS Edge as a workaround. We will keep you advised once we have a resolution from 8x8.
Posted Oct 16, 2025 - 11:25 EDT
This incident affected: Phone System (Virtual Call Center).