Global AWS Outage may be impacting external interfaces and services you connect to

Incident Report for Responsive Auto

Resolved

AWS outage has been resolved. Please open a ticket if you continue experiencing issues.
Posted Oct 21, 2025 - 12:41 EDT

Identified

Amazon is working on fixes but we do not have an ETA for resolution.

We will share any updates as they become available.

The vendors should be sharing updates with you as their services are restored.
Posted Oct 20, 2025 - 12:39 EDT

Investigating

There is a global AWS outage that may be impacting interfaces or services that you use. We are not aware of all the different services that use AWS but some that have come to our attention are:
CCC
ISO ClaimSearch

If you are experiencing issues, please open a service desk ticket and Infrastructure can help to determine whether it is part of the outage or another issue.
Posted Oct 20, 2025 - 12:36 EDT
This incident affected: Responsive Software (CCC Service).